How do you disable the "Device no response" message?

How do you disable the "Device no response" message?
none 0.0 0

When a remote I/O device on Modbus TCP/IP or RTU loses communication to the HMI, a prompt displays saying “ERROR - NO REMOTE IO RESPONSE”.

Is there any way to turn off and ignore this error?

Hi @itsmomito,

While we don’t recommend that the connectivity error message be disabled, it is possible with a system tag. Within the “Address Tag Library”, in the “System tags” list, select the “Device No Response” tag that corresponds to the number of the device that is producing the connectivity error message.

The address tag library can be found within the “Library” section of the “Project” tab:


You can find your device number in the “System Parameter Settings” menu:

Thank you, this helps a lot! While I aim to turn off this connectivity error message, I would still like to know if there are connectivity errors with devices, on a separate page. Is there an address I can read that indicates a modbus TCP/IP no response? I used these addresses which are connected to error codes, but the error code doesn’t seem to reset after the ethernet connection has been restored:

Hi @itsmomito,

Instead of using a system tag to view communication error codes, try using a system tag that displays the device status as on or off. Search “status” in our “Address Tag Library” and choose the tag that corresponds with your device number and connection type (i.e., “LB-9200: device 1 status (SN0, COM 1), set on to retry connection”. In this example, SN0 = Station Number 0).


I tried this approach but unfortunately it doesn’t seem to accurately reflect the state of the ethernet connection. When I remove the connection, it seems to stay the same. Is it perhaps because the value is set to ON by default in order to ensure that the connection is automatically restarted? Is there another parameter I can refer to that has real time indication of the ethernet status?

Perhaps you should use the CMT Diagnoser instead of using system registers.
Please look at this user manual, specifically section 31.3.3. “Packet Settings”

The available tags are only for the device ID. What about the station numbers in Modbus RTU? Is there a way to disable them?

Hi @MondiM,

The station number is denoted by “SN” within certain system tags as in SN0 or SN1. The “Device no response” message cannot be disabled for specific station numbers. It can only be enabled / disabled for a target device ID related to the driver used to connect with the target device(s).