How to properly use the Media Player with multiple videos

How to properly use the Media Player with multiple videos
none 0.0 0
  • HMI Model: cMT3162x(V2)
  • EasyBuilder Pro Version: 6.08.02
  • Serial Number or supplier: HH Barnum

Hello All,

I am having an issue with utilizing the media player that EasyBuilder provides for on screen support videos via a USB stick.

In the project, there are 3 videos, each on their perspective “Pop-ups” when the operator will press for whichever video they need. I wanted to utilize the built in media player, as this seemed to most practical, however, it does not seem to be working.

I tried following the manual, but wondering if I missed a step or if something is wrong.

For each video (named: video-Test1, video-Test2, video-Test3), I placed the MP4 videos onto the root USB with no other folders or files. In the properties of each media player, I named the folder path to match.
I then went to the preview tab and the video played as expected.

However, once I plugged the USB into the HMIs port, and went to the respective Pop-up, the media player would just display a black screen.

I know the HMI detected the USB as it asked the generic question up Upload/Download or nothing when the USB drive was inserted. I just can not seem to get the videos to play.

Am I missing something?

The OS version was a 2023… so definitely newer than the minimum version required.


Popup Example

Media Player Properties

Hi @jonmarc91,

The folder path should be the name of the folder that contains your video files. As an example, the default “Folder name” is “video” meaning that video files must be placed within a folder called “video” in order to be accessible to the media player. When the media player is displayed, you can click the play button to play the video files in that folder:

Hi @Brendon.S,

I did test that too, where each video was placed under the respective folder so maybe that was my next test problem by not using “video”?
I tried:

Since I am not using the UI or commands, the play button does not appear. When I do re-enable the UI controls, the play button appears but it does not do show anything.

Since there are multiple videos wanting to be played, would they all go in a “Video” folder? In the following, trying to show all videos under a common “video” folder
Example: video/video-Test1
Example: video/video-Test2
Example: video/video-Test3


The folder does not have to be called “video” in order for this method to work. I have used your folder naming convention in a simple test project with one folder called “video-Test1” that contains one video without any issue.


Thank you for the assistance. To recap what was found and solution to the issue was the incorrect formatting of the USB stick that the videos were being stored on.

The USB must be formatted in FAT or FAT32 to be read by the cMT3162x.

Once this was changed, the videos started playing.
The folder structure did work as you mentioned, where the video1, video2, video3 could be put under their respective folders in the USB.

Example: video1/video-Test1
Example: video2/video-Test2
Example: video3/video-Test3

Thanks again!

1 Like

Hi @jonmarc91,

Thank you for the update, we are happy to hear that this issue is resolved!